[ Bug Report ] OpenGL detection problem with main SGN launcher (v4.0.2)



  • Bug Report:

    Trying the new SGN demo on Windows 7 64bit with an HD3000 intel graphic card (1.5 GB Ram, DirectX11/OpenGL 3.3 compatible, and driver version 9.17.10.4229) I’m experiencing a problem with the SGN Launcher (version 4.0.2). At first launch and also when it tries auto-starting its updated version keeps displaying the following error message:

    "Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags< QSurfaceForrnat::Format0ption > (), depthBufferSize 24,
    redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swaplnterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile QSurfaceFormat::OpenGLContextProfile(NoProfile)).
    This is most likely caused by not having the necessary graphics drivers installed.
    Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dlI, libGLESv2.dll and d3dcompiler__*.dll) are available in the application executable’s directory or in a location listed in PATH."

    I’ve also looked for an automatic error log in the Launcher (local) installation directory (under Documents) and in some temp dir. (like under AppData/Local AppData/Roaming etc…), but there is nothing like that.

    Thanks for the attention.
    AnonGate


  • SGN

    Thanks for your report, we are checking this issue.



  • ça ne fonctionne pas car il n’a pas le minimum requis pour faire tourner opengl2.0.

    Sa “carte graphique” HD3000 d’intel ne gère pas l’opengl 2.0, j’ai eu un souci similaire avec un eeepc pour lancer don’t starve together.

    j’ai eu le même message d’erreur en voulant lancer l’installation de stargate network depuis un client RDP.

    je passe par Anydesk et pas de souci, aucun souci en étant devant le PC directement.

    Son souci est donc que ça machine ne peut pas faire tourner le launcher ni le jeu (en même temps vu la config …)



  • This post is deleted!

  • SGN

    Fixed in the next version



  • I’ve just tried the new alpha-version and now SGN-Launcher works as expected.
    Changing BugReport status to “Fixed”, (I would like to do this also on Topic title but it seems that, correct me if I’m wrong, changing Topic titles it’s not possible).

    Thank you.
    AnonGate


Log in to reply
 

Looks like your connection to Stargate Network was lost, please wait while we try to reconnect.